Mod/Plugin Manager

If you are running a Bukkit-based/Modded Minecraft instance, then you will be able to use the "Plugins"/"Mods" sub-menu for your Minecraft: Java Edition instance.

NOTE: You will not be able to use the Plugins/Mods menu's if the installation does not contain the appropriate folders. These folders are generated during startup with the applicable software:
Vanilla Minecraft can not load mods or plugins.
Bukkit-based Minecraft can load plugins (Not mods).
Forge-based Minecraft can load mods (Not plugins).
Hybrid software can load mods and plugins, however, depending on which software you opt for is unsupported, depreciated and unstable. We recommend 1.10.x+ mod servers can use SpongeForge to load plugins.

  • View installed plugins/mods

    All detected plugins/mods will be listed on the Plugins/Mods Manager.
    You can click the buttons on the right side of the plugin or mod to disable or enable them. Disabled plugins/mods are renamed to prevent them loading with the .disabled filetype.
  • Upload plugins/mods from your PC

    Drag a plugin/mod jar file into the [Upload] box at the top of the Plugins/Mods Manager. Note: If the plugin/mod is too big, it may not upload via the browser, you would need to upload it via sFTP/SSH to the corresponding plugins or mods folder for your instances directory.
  • Install plugins from Bukkit or mods from Curse:

    Type the plugin/mod name into the search bar at the top of the Plugins/Mods menu, then click search. This may take a few seconds/minutes depending on the speed of the search. Once your plugin or mod has been found it will appear with a drop-down box next to it and an install button.
    The drop-down box dictates which 'build' you want installing, you can select older builds via this box, the newer build should always be displayed first.

    NOTE: Make sure to type the correct plugin/mod name, especially for modded searches, as "Exnihilo" is not the same as "Ex Nihilo", if the Bukkit/Curse website cannot display the correct results on their website, our panel will likely not be able to display an install for it either.